<!DOCTYPE html>
<!--[if lt IE 7]><html class="lt-ie9 lt-ie8 lt-ie7 no-js" lang="en-US"><![endif]-->
<!--[if IE 7]><html class="lt-ie9 lt-ie8 no-js" lang="en-US"><![endif]-->
<!--[if IE 8]><html class="lt-ie9 no-js" lang="en-US"><![endif]-->
<!--[if gt IE 8]><!--><html class="no-js" lang="en-US"><!--<![endif]-->
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<title>‘Even if it’s tomorrow or a thousand years’ &#8211; ‘Unashamed’ faith of Logan Davis revealed wisdom beyond his 18 years &#8211; Diocese of Owensboro</title>
<title>‘Even if it’s tomorrow or a thousand years’ &#8211; ‘Unashamed’ faith of Logan Davis revealed wisdom beyond his 18 years &#8211; Diocese of Owensboro</title>
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Diocese of Owensboro &raquo; Feed" href="https://owensborodiocese.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Diocese of Owensboro &raquo; Comments Feed" href="https://owensborodiocese.org/comments/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ai1ec_style-css' href='//owensborodiocese.org/wp-content/plugins/all-in-one-event-calendar/public/themes-ai1ec/vortex/css/ai1ec_parsed_css.css?ver=2.6.7' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://owensborodiocese.org/wp-includes/css/dist/block-library/style.min.css?ver=2ee5fdeb12d9b11e4dfc9f800f3d4c4b' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='app-banners-styles-css' href='https://owensborodiocese.org/wp-content/plugins/appbanners/lib/smartbanner/jquery.smartbanner.min.css?ver=2ee5fdeb12d9b11e4dfc9f800f3d4c4b' type='text/css' media='all' />
<link rel='stylesheet' id='cookie-consent-style-css' href='https://owensborodiocese.org/wp-content/plugins/uk-cookie-consent/assets/css/style.css?ver=2ee5fdeb12d9b11e4dfc9f800f3d4c4b' type='text/css' media='all' />
<link rel='stylesheet' id='dlm-frontend-css' href='https://owensborodiocese.org/wp-content/plugins/download-monitor/assets/css/frontend.css?ver=2ee5fdeb12d9b11e4dfc9f800f3d4c4b' type='text/css' media='all' />
<link rel='stylesheet' id='theme-style-turf-css' href='https://owensborodiocese.org/wp-content/themes/owensborodiocese/turf/css/turf.css?ver=6.4.19' type='text/css' media='all' />
<link rel='stylesheet' id='theme-style-css' href='https://owensborodiocese.org/wp-content/themes/owensborodiocese/style.css?ver=1.0.19.1' type='text/css' media='all' />
<link rel='stylesheet' id='rps-turf-style-options-css' href='https://owensborodiocese.org/wp-content/themes/owensborodiocese/style-options.css?ver=6.4.19' type='text/css' media='' />
<link rel='stylesheet' id='tablepress-default-css' href='https://owensborodiocese.org/wp-content/plugins/tablepress/css/default.min.css?ver=1.12' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://owensborodiocese.org/wp-content/plugins/jetpack/css/jetpack.css?ver=8.9' type='text/css' media='all' />
<script type='text/javascript' src='https://owensborodiocese.org/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' src='https://owensborodiocese.org/wp-content/themes/owensborodiocese/turf/js/modernizr.min.js?ver=2.8.3' id='rps-turf-script-modernizr-js'></script>
<link rel="https://api.w.org/" href="https://owensborodiocese.org/wp-json/" /><link rel="alternate" type="application/json" href="https://owensborodiocese.org/wp-json/wp/v2/posts/8929" /><link rel="canonical" href="https://owensborodiocese.org/2020/09/15/unashamed-faith-logan-davis-revealed-wisdom-beyond-18-years/" />
<link rel='shortlink' href='https://owensborodiocese.org/?p=8929' />
<meta name="apple-itunes-app" content="app-id=613643913">
<meta name="google-play-app" content="app-id=com.redpixel.infoapp.m.client.dioceseowensboro">
<meta name="author" content="Red Pixel Studios, Inc.">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<style id="ctcc-css" type="text/css" media="screen">
				#catapult-cookie-bar {
					box-sizing: border-box;
					max-height: 0;
					opacity: 0;
					z-index: 99999;
					overflow: hidden;
					color: #ffffff;
					position: fixed;
					left: 0;
					top: 0;
					width: 100%;
					background-color: #464646;
				}
				#catapult-cookie-bar a {
					color: #fff;
				}
				#catapult-cookie-bar .x_close span {
					background-color: ;
				}
				button#catapultCookie {
					background:;
					color: ;
					border: 0; padding: 6px 9px; border-radius: 3px;
				}
				#catapult-cookie-bar h3 {
					color: #ffffff;
				}
				.has-cookie-bar #catapult-cookie-bar {
					opacity: 1;
					max-height: 999px;
					min-height: 30px;
				}</style><link rel="icon" href="https://owensborodiocese.org/wp-content/themes/owensborodiocese/_favicons/speeddial-160px.png" type="image/png">
<link rel="icon" href="https://owensborodiocese.org/wp-content/themes/owensborodiocese/_favicons/apple-touch-icon-114x114-precomposed.png" sizes="114x114">
<link rel="icon" href="https://owensborodiocese.org/wp-content/themes/owensborodiocese/_favicons/apple-touch-icon-72x72-precomposed.png" sizes="72x72">
<link rel="icon" href="https://owensborodiocese.org/wp-content/themes/owensborodiocese/_favicons/apple-touch-icon-57x57-precomposed.png">
<!--[if lt IE 9]><script type="text/javascript" src="https://owensborodiocese.org/wp-content/themes/owensborodiocese/turf/js/html5shiv.js?ver=6.4.19"></script><![endif]--><!--[if gt IE 8]><script type="text/javascript" src="https://owensborodiocese.org/wp-content/themes/owensborodiocese/turf/js/html5shiv.js?ver=6.4.19"></script><![endif]-->

<meta property="og:type" content="article" />
<meta property="og:title" content="‘Even if it’s tomorrow or a thousand years’ &#8211; ‘Unashamed’ faith of Logan Davis revealed wisdom beyond his 18 years" />
<meta property="og:url" content="https://owensborodiocese.org/2020/09/15/unashamed-faith-logan-davis-revealed-wisdom-beyond-18-years/" />
<meta property="og:description" content="BY ELIZABETH WONG BARNSTEAD, THE WESTERN KENTUCKY CATHOLICLogan Davis’s sister, Haley Davis, is the one who discovered the journal.They hadn’t known that Logan had kept a journal. And “it wasn’t so…" />
<meta property="article:published_time" content="2020-09-15T14:56:28+00:00" />
<meta property="article:modified_time" content="2020-09-18T14:56:41+00:00" />
<meta property="og:site_name" content="Diocese of Owensboro" />
<meta property="og:image" content="https://owensborodiocese.org/wp-content/uploads/LoganDavis_HaleyAndKarla_SeptWKC2020online.jpg" />
<meta property="og:image:width" content="1500" />
<meta property="og:image:height" content="600" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="‘Even if it’s tomorrow or a thousand years’ &#8211; ‘Unashamed’ faith of Logan Davis revealed wisdom beyond his 18 years" />
<meta name="twitter:image" content="https://owensborodiocese.org/wp-content/uploads/LoganDavis_HaleyAndKarla_SeptWKC2020online.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<style type="text/css" id="wp-custom-css">
			.rps-contact-item-value ~ .rps-contact-item-value {
	margin-top:0 !important;
}
.rps-contact-heading {
	margin-top:2rem !important;
}
.rps-contact-heading:empty {
	display: none !important;
}
.rps-contact-item-type-company-title {
	font-weight: bold;
}
.type-rps_contact > header {
	margin-bottom: 0 !important;
}
.type-rps_contact > .e-content {
	margin-top: 0 !important;
}
#catapult-cookie-bar,
button#catapultCookie {
	font-size: 1rem;
}		</style>
<!--[if gt IE 8]--><script type="text/javascript" src="https://owensborodiocese.org/wp-content/themes/owensborodiocese/turf/js/masonry.js?ver=6.4.19"></script><!--[endif]--></head>
<body class="post-template-default single single-post postid-8929 single-format-standard turf theme turf-post-type-post turf-template-single turf-inside turf-theme-owensborodiocese turf-comments-closed turf-slug-unashamed-faith-logan-davis-revealed-wisdom-beyond-18-years turf-single turf-category-the-western-kentucky-catholic two-row">
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-7449442-1', 'auto');
  ga('send', 'pageview');

</script><nav role="navigation" class="nav index" data-multi-level="true" data-depth="4"><h1>&nbsp;</h1><ul class="rps-nav-menus"><li class="menu-item menu-item-290 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="290" href="https://owensborodiocese.org/our-diocese/"><span>Our Diocese</span></a><ul class="sub-menu"><li class="menu-item menu-item-294 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="294" href="https://owensborodiocese.org/history/"><span>History</span></a></li><li class="menu-item menu-item-1438 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="1438" href="https://owensborodiocese.org/the-bishop/"><span>The Bishop</span></a><ul class="sub-menu"><li class="menu-item menu-item-867 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="867" href="https://owensborodiocese.org/prayer-for-bishop-medley/"><span>Prayer for Bishop Medley</span></a></li></ul></li><li class="menu-item menu-item-291 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="291" href="https://owensborodiocese.org/canonical-offices/"><span>Canonical Offices</span></a></li><li class="menu-item menu-item-289 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="289" href="https://owensborodiocese.org/offices/"><span>McRaith Catholic Center Offices</span></a><ul class="sub-menu"><li class="menu-item menu-item-8170 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="8170" href="https://owensborodiocese.org/diocesan-archives/"><span>Archives</span></a><ul class="sub-menu"><li class="menu-item menu-item-7794 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="7794" href="https://owensborodiocese.org/history-of-the-archives/"><span>About</span></a></li><li class="menu-item menu-item-7807 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="7807" href="https://owensborodiocese.org/collections-overview/"><span>Collections</span></a></li><li class="menu-item menu-item-7806 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="7806" href="https://owensborodiocese.org/sacramental-registers-in-the-archives/"><span>Sacramental Records</span></a></li><li class="menu-item menu-item-7801 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="7801" href="https://owensborodiocese.org/genealogy-resources/"><span>Genealogy</span></a></li><li class="menu-item menu-item-7802 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="7802" href="https://owensborodiocese.org/ask-the-archivist/"><span>Research</span></a></li></ul><li class="menu-item menu-item-654 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="654" href="https://owensborodiocese.org/black-catholic-ministry/"><span>Black Catholic Ministry</span></a><ul class="sub-menu"><li class="menu-item menu-item-3110 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="3110" href="https://owensborodiocese.org/bibles/"><span>Bibles</span></a></li></ul><li class="menu-item menu-item-3797 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="3797" href="https://owensborodiocese.org/catholic-cemeteries/"><span>Catholic Cemeteries</span></a></li><li class="menu-item menu-item-655 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="655" href="https://owensborodiocese.org/catholic-charities/"><span>Catholic Charities</span></a><ul class="sub-menu"><li class="menu-item menu-item-870 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="870" href="https://owensborodiocese.org/counseling/"><span>Counseling Resources</span></a></li><li class="menu-item menu-item-7107 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="7107" href="https://owensborodiocese.org/immigration-legal-services/"><span>Immigration Legal Services</span></a></li><li class="menu-item menu-item-8232 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="8232" href="https://owensborodiocese.org/john-j-mcraith-providing-help-creating-hope-award/"><span>John J. McRaith Providing Help, Creating Hope Award</span></a></li><li class="menu-item menu-item-7043 menu-item-type-custom menu-item-object-custom menu-slug-primary"><a menu-id="7043" href="https://opportunitiesforlife.org/"><span>Opportunities for Life</span></a></li><li class="menu-item menu-item-872 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="872" href="https://owensborodiocese.org/saint-gerard/"><span>Saint Gerard Life Home</span></a></li><li class="menu-item menu-item-877 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="877" href="https://owensborodiocese.org/vehicle-donation-program/"><span>Vehicle Donation Program</span></a></li></ul><li class="menu-item menu-item-656 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="656" href="https://owensborodiocese.org/catholic-schools/"><span>Catholic Schools</span></a><ul class="sub-menu"><li class="menu-item menu-item-8785 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="8785" href="https://owensborodiocese.org/resources-for-re-opening-catholic-schools/"><span>Resources for Re-Opening Catholic Schools</span></a></li><li class="menu-item menu-item-8871 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="8871" href="https://owensborodiocese.org/covid19-school-reporting/"><span>Reporting COVID-19 in Catholic Schools</span></a></li><li class="menu-item menu-item-858 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="858" href="https://owensborodiocese.org/academic-standards/"><span>Academic Standards</span></a></li><li class="menu-item menu-item-940 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="940" href="https://owensborodiocese.org/non-discrimination-statement/"><span>Non-Discrimination Statement</span></a></li><li class="menu-item menu-item-857 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="857" href="https://owensborodiocese.org/school-directory/"><span>School Directory</span></a></li><li class="menu-item menu-item-2556 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="2556" href="https://owensborodiocese.org/student-accident-insurance/"><span>Student Accident Insurance</span></a></li><li class="menu-item menu-item-4669 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="4669" href="https://owensborodiocese.org/catholic-school-resources/"><span>Catholic School Resources</span></a></li></ul><li class="menu-item menu-item-657 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="657" href="https://owensborodiocese.org/communications/"><span>Communications</span></a><ul class="sub-menu"><li class="menu-item menu-item-818 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="818" href="https://owensborodiocese.org/western-kentucky-catholic/"><span>The Western Kentucky Catholic</span></a></li><li class="menu-item menu-item-844 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="844" href="https://owensborodiocese.org/across-the-diocese/"><span>Across the Diocese</span></a></li><li class="menu-item menu-item-846 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="846" href="https://owensborodiocese.org/e-newsletter/"><span>E-Newsletter</span></a></li><li class="menu-item menu-item-848 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="848" href="https://owensborodiocese.org/social-media/"><span>Social Media</span></a></li></ul><li class="menu-item menu-item-1465 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="1465" href="https://owensborodiocese.org/ecumenism/"><span>Ecumenism</span></a><ul class="sub-menu"><li class="menu-item menu-item-1463 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1463" href="https://owensborodiocese.org/ecumenical-meaning/"><span>Ecumenical Meaning</span></a></li><li class="menu-item menu-item-1462 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1462" href="https://owensborodiocese.org/practicing-ecumenism/"><span>Practicing Ecumenism</span></a></li><li class="menu-item menu-item-1464 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1464" href="https://owensborodiocese.org/ecumenism-faq/"><span>Ecumenism FAQ</span></a></li></ul><li class="menu-item menu-item-4286 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="4286" href="https://owensborodiocese.org/evangelization/"><span>Evangelization &#038; Discipleship</span></a><ul class="sub-menu"><li class="menu-item menu-item-6845 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="6845" href="https://owensborodiocese.org/evangelization-resources/"><span>Evangelization Resources</span></a></li><li class="menu-item menu-item-8462 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="8462" href="https://owensborodiocese.org/discipleship-resources/"><span>Discipleship Resources</span></a></li><li class="menu-item menu-item-5391 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="5391" href="https://owensborodiocese.org/encounter/"><span>Encounter</span></a></li><li class="menu-item menu-item-5664 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="5664" href="https://owensborodiocese.org/accompany/"><span>Accompany</span></a></li><li class="menu-item menu-item-8018 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="8018" href="https://owensborodiocese.org/community/"><span>Community</span></a></li></ul><li class="menu-item menu-item-659 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="659" href="https://owensborodiocese.org/faith-formation/"><span>Faith Formation</span></a><ul class="sub-menu"><li class="menu-item menu-item-7503 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="7503" href="https://owensborodiocese.org/certification-for-religious-educators/"><span>Certification for Religious Educators</span></a></li><li class="menu-item menu-item-8935 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="8935" href="https://owensborodiocese.org/family-ministry-resources/"><span>Family Ministry Resources</span></a></li><li class="menu-item menu-item-2914 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="2914" href="https://owensborodiocese.org/faith-formation-forms/"><span>Forms</span></a></li><li class="menu-item menu-item-909 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="909" href="https://owensborodiocese.org/media-center/"><span>Media Center</span></a></li></ul><li class="menu-item menu-item-8680 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="8680" href="https://owensborodiocese.org/finance/"><span>Finance</span></a><ul class="sub-menu"><li class="menu-item menu-item-1864 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1864" href="https://owensborodiocese.org/financial-documents-and-forms/"><span>Documents</span></a></li><li class="menu-item menu-item-5364 menu-item-type-custom menu-item-object-custom menu-slug-primary"><a menu-id="5364" href="https://owensborodiocese.org/diocesan-forms/"><span>Forms</span></a></li><li class="menu-item menu-item-5365 menu-item-type-custom menu-item-object-custom menu-slug-primary"><a menu-id="5365" href="https://owensborodiocese.org/administration-and-finance-policies/"><span>Policies</span></a></li><li class="menu-item menu-item-5368 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="5368" href="https://owensborodiocese.org/diocesan-reports/"><span>Reports</span></a></li></ul><li class="menu-item menu-item-1023 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1023" href="https://owensborodiocese.org/camp/"><span>Gasper River Camp and Retreat Center</span></a></li><li class="menu-item menu-item-1741 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="1741" href="https://owensborodiocese.org/human-resources/"><span>Human Resources</span></a><ul class="sub-menu"><li class="menu-item menu-item-1742 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="1742" href="https://owensborodiocese.org/employment/"><span>Employment</span></a></li><li class="menu-item menu-item-1746 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="1746" href="https://owensborodiocese.org/hr-intranet/"><span>HR Intranet</span></a></li><li class="menu-item menu-item-2668 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="2668" href="https://owensborodiocese.org/health-care/"><span>Health Care & Enrollment</span></a></li></ul><li class="menu-item menu-item-5643 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="5643" href="https://owensborodiocese.org/office-of-marriage-family-life/"><span>Marriage & Family Life</span></a><ul class="sub-menu"><li class="menu-item menu-item-5634 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="5634" href="https://owensborodiocese.org/marriage-preparation/"><span>Marriage Preparation</span></a></li><li class="menu-item menu-item-5635 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="5635" href="https://owensborodiocese.org/marriage-family-enrichment/"><span>Marriage &#038; Family Enrichment</span></a></li><li class="menu-item menu-item-5636 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="5636" href="https://owensborodiocese.org/support-counseling-services/"><span>Support &#038; Counseling Services</span></a></li><li class="menu-item menu-item-5637 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="5637" href="https://owensborodiocese.org/natural-family-planning/"><span>Natural Family Planning</span></a></li><li class="menu-item menu-item-7387 menu-item-type-custom menu-item-object-custom menu-slug-primary"><a menu-id="7387" href="https://cleanheartinitiative.org/"><span>Clean Heart Initiative</span></a></li></ul><li class="menu-item menu-item-661 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="661" href="https://owensborodiocese.org/ministerio-hispano/"><span>Ministerio Hispano</span></a><ul class="sub-menu"><li class="menu-item menu-item-8616 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="8616" href="https://owensborodiocese.org/v-encuentro/"><span>V Encuentro</span></a></li><li class="menu-item menu-item-3396 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="3396" href="https://owensborodiocese.org/declaracion-del-obispo-sobre-inmigracion/"><span>Declaración del Obispo sobre Inmigración</span></a></li><li class="menu-item menu-item-3417 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="3417" href="https://owensborodiocese.org/hispanic-ministry-calendar/"><span>Calendario</span></a></li><li class="menu-item menu-item-2206 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="2206" href="https://owensborodiocese.org/cristo-renueva-su-parroquia/"><span>Cristo Renueva Su Parroquia</span></a></li><li class="menu-item menu-item-2232 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="2232" href="https://owensborodiocese.org/parroquias-con-misa-en-espanol/"><span>Parroquias Con Misa En Espanol</span></a></li><li class="menu-item menu-item-925 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="925" href="https://owensborodiocese.org/justice-for-immigrants/"><span>Justice for Immigrants</span></a></li></ul><li class="menu-item menu-item-662 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="662" href="https://owensborodiocese.org/music/"><span>Music</span></a><ul class="sub-menu"><li class="menu-item menu-item-6827 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="6827" href="https://owensborodiocese.org/chrism-mass-music-files/"><span>Chrism Mass Music Files</span></a></li></ul><li class="menu-item menu-item-1924 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1924" href="https://owensborodiocese.org/ongoing-formation-for-priests/"><span>Ongoing Formation For Priests</span></a></li><li class="menu-item menu-item-2022 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="2022" href="https://owensborodiocese.org/pastoral-juvenil/"><span>Pastoral Juvenil</span></a></li><li class="menu-item menu-item-665 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="665" href="https://owensborodiocese.org/safe/"><span>Safe Environment</span></a><ul class="sub-menu"><li class="menu-item menu-item-6477 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="6477" href="https://owensborodiocese.org/becoming-safe-environment-compliant/"><span>Becoming Safe Environment Compliant</span></a></li><li class="menu-item menu-item-700 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="700" href="https://owensborodiocese.org/reporting/"><span>Reporting and Healing</span></a></li><li class="menu-item menu-item-7052 menu-item-type-custom menu-item-object-custom menu-slug-primary"><a menu-id="7052" href="https://owensborodiocese.org/list/"><span>Clergy with Substantiated Allegations</span></a></li><li class="menu-item menu-item-718 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="718" href="https://owensborodiocese.org/safe-environment-documents/"><span>Documents and Forms</span></a></li><li class="menu-item menu-item-701 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="701" href="https://owensborodiocese.org/training-minors-2/"><span>Training Minors: Circle of Grace</span></a></li><li class="menu-item menu-item-698 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="698" href="https://owensborodiocese.org/tools/"><span>Tools and Resources</span></a></li><li class="menu-item menu-item-6394 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="6394" href="https://owensborodiocese.org/charter-mission/"><span>Charter &#038; Mission</span></a></li><li class="menu-item menu-item-6749 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="6749" href="https://owensborodiocese.org/ambiente-seguro-compatible/"><span>Ambiente Seguro</span></a></li></ul><li class="menu-item menu-item-666 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="666" href="https://owensborodiocese.org/school-food-service/"><span>School Food Service</span></a><ul class="sub-menu"><li class="menu-item menu-item-673 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="673" href="https://owensborodiocese.org/food-service-documents/"><span>Food Service Documents</span></a></li><li class="menu-item menu-item-2062 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="2062" href="https://owensborodiocese.org/non-discrimination-statement-2/"><span>Non-Discrimination Statement</span></a></li><li class="menu-item menu-item-674 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="674" href="https://owensborodiocese.org/parent-cafeteria-information/"><span>Parent Cafeteria Information</span></a></li><li class="menu-item menu-item-676 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="676" href="https://owensborodiocese.org/summer-food-service-program/"><span>Summer Food Service Program</span></a></li><li class="menu-item menu-item-3364 menu-item-type-custom menu-item-object-custom menu-slug-primary"><a menu-id="3364" href="https://owensborodiocese.org/wp-content/uploads/Wellness.pdf"><span>Wellness</span></a></li></ul><li class="menu-item menu-item-667 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="667" href="https://owensborodiocese.org/social-concerns/"><span>Social Concerns</span></a><ul class="sub-menu"><li class="menu-item menu-item-4703 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="4703" href="https://owensborodiocese.org/cchd/"><span>Catholic Campaign for Human Development Grant</span></a></li><li class="menu-item menu-item-3910 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="3910" href="https://owensborodiocese.org/aging-mastery-program/"><span>Aging Mastery Program</span></a></li><li class="menu-item menu-item-927 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="927" href="https://owensborodiocese.org/diocesan-social-justice-committee/"><span>Diocesan Social Justice Committee</span></a></li><li class="menu-item menu-item-928 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="928" href="https://owensborodiocese.org/disabilities-awareness-committee/"><span>Disabilities Awareness Committee</span></a></li><li class="menu-item menu-item-931 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="931" href="https://owensborodiocese.org/gospel-of-life/"><span>Gospel of Life Committee</span></a></li><li class="menu-item menu-item-929 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="929" href="https://owensborodiocese.org/rural-life-committee/"><span>Rural Life Committee</span></a></li><li class="menu-item menu-item-930 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="930" href="https://owensborodiocese.org/mandeville-sister-diocese/"><span>Mandeville Sister Diocese</span></a></li><li class="menu-item menu-item-932 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="932" href="https://owensborodiocese.org/prison-ministry/"><span>Prison Ministry</span></a></li></ul><li class="menu-item menu-item-668 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="668" href="https://owensborodiocese.org/stewardship/"><span>Stewardship</span></a><ul class="sub-menu"><li class="menu-item menu-item-2753 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="2753" href="https://owensborodiocese.org/annual-appeal/"><span>Disciples Response Fund Annual Appeal</span></a></li><li class="menu-item menu-item-2068 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="2068" href="https://owensborodiocese.org/give/"><span>Give</span></a></li><li class="menu-item menu-item-1419 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="1419" href="https://owensborodiocese.org/stewardship-resources/"><span>Resources</span></a></li><li class="menu-item menu-item-2119 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="2119" href="https://owensborodiocese.org/sophia/"><span>Sophia Awards</span></a></li></ul><li class="menu-item menu-item-1865 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1865" href="https://owensborodiocese.org/technology/"><span>Technology</span></a></li><li class="menu-item menu-item-669 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="669" href="https://owensborodiocese.org/tribunal/"><span>Tribunal</span></a><ul class="sub-menu"><li class="menu-item menu-item-7883 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="7883" href="https://owensborodiocese.org/marriage-forms/"><span>Marriage Forms</span></a></li><li class="menu-item menu-item-7595 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="7595" href="https://owensborodiocese.org/tribunal-explains/"><span>Tribunal Explains</span></a></li></ul><li class="menu-item menu-item-670 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="670" href="https://owensborodiocese.org/vocations/"><span>Vocations</span></a><ul class="sub-menu"><li class="menu-item menu-item-1868 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1868" href="https://owensborodiocese.org/priesthood/"><span>Priesthood</span></a></li><li class="menu-item menu-item-1871 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1871" href="https://owensborodiocese.org/permanent-diaconate/"><span>Permanent Diaconate</span></a></li><li class="menu-item menu-item-1869 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1869" href="https://owensborodiocese.org/men-religious/"><span>Men Religious</span></a></li><li class="menu-item menu-item-1870 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1870" href="https://owensborodiocese.org/women-religious/"><span>Women Religious</span></a></li></ul><li class="menu-item menu-item-671 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="671" href="https://owensborodiocese.org/worship/"><span>Worship</span></a><ul class="sub-menu"><li class="menu-item menu-item-8291 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="8291" href="https://owensborodiocese.org/resources-for-prayer-at-home/"><span>Resources for Prayer at Home</span></a></li><li class="menu-item menu-item-8303 menu-item-type-custom menu-item-object-custom menu-slug-primary menu-item-has-children"><a menu-id="8303" href="https://owensborodiocese.org/covid-2019/"><span>COVID-19 Updates</span></a></li><li class="menu-item menu-item-7858 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="7858" href="https://owensborodiocese.org/rite-of-election/"><span>Rite of Election</span></a></li><li class="menu-item menu-item-4423 menu-item-type-custom menu-item-object-custom menu-slug-primary"><a menu-id="4423" href="https://owensborodiocese.org/wp-content/uploads/Liturgical-Year-2020_rev.pdf"><span>2020 Liturgical Year</span></a></li><li class="menu-item menu-item-8711 menu-item-type-custom menu-item-object-custom menu-slug-primary"><a menu-id="8711" href="https://owensborodiocese.org/wp-content/uploads/Liturgical-Year-2021.pdf"><span>2021 Liturgical Year</span></a></li><li class="menu-item menu-item-1826 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1826" href="https://owensborodiocese.org/confirmation/"><span>Confirmation</span></a></li><li class="menu-item menu-item-6627 menu-item-type-custom menu-item-object-custom menu-slug-primary"><a menu-id="6627" href="https://owensborodiocese.org/wp-content/uploads/Guidelines-for-the-Celebration-of-the-Sacraments-with-Persons-with-Disabilities-Revised-Edition.pdf"><span>Guidelines for the Celebration of the Sacraments with Persons with Disabilities</span></a></li><li class="menu-item menu-item-1825 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="1825" href="https://owensborodiocese.org/rcia-resources/"><span>RCIA Coordinator Resources</span></a></li><li class="menu-item menu-item-1484 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1484" href="https://owensborodiocese.org/parish-liturgy-manual/"><span>Parish Liturgy Manual</span></a></li><li class="menu-item menu-item-7374 menu-item-type-custom menu-item-object-custom menu-slug-primary"><a menu-id="7374" href="https://owensborodiocese.org/wp-content/uploads/LTP-Order-Form-2021-Fillable.pdf"><span>LTP Annual Liturgical Resource Order Form</span></a></li><li class="menu-item menu-item-7937 menu-item-type-custom menu-item-object-custom menu-slug-primary"><a menu-id="7937" href="https://owensborodiocese.org/wp-content/uploads/Word-of-God-Sunday.pdf"><span>Sunday of the Word of God</span></a></li></ul><li class="menu-item menu-item-5565 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="5565" href="https://owensborodiocese.org/young-adult-ministry/"><span>Young Adult Ministry</span></a></li><li class="menu-item menu-item-5043 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="5043" href="https://owensborodiocese.org/youth-ministry/"><span>Youth Ministry</span></a><ul class="sub-menu"><li class="menu-item menu-item-5179 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="5179" href="https://owensborodiocese.org/middle-school-youth/"><span>Middle School Youth</span></a></li><li class="menu-item menu-item-5180 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="5180" href="https://owensborodiocese.org/high-school-youth/"><span>High School Youth</span></a></li><li class="menu-item menu-item-5562 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="5562" href="https://owensborodiocese.org/young-adult-ministry/"><span>Young Adult Ministry</span></a></li></ul></ul></li><li class="menu-item menu-item-5377 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="5377" href="https://owensborodiocese.org/financial-documents-and-forms/"><span>Diocesan Documents</span></a></li><li class="menu-item menu-item-4409 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="4409" href="https://owensborodiocese.org/diocesan-forms/"><span>Diocesan Forms</span></a></li><li class="menu-item menu-item-4410 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="4410" href="https://owensborodiocese.org/diocesan-policies/"><span>Diocesan Policies</span></a><ul class="sub-menu"><li class="menu-item menu-item-4731 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="4731" href="https://owensborodiocese.org/administration-and-finance-policies/"><span>Administration and Finance</span></a></li><li class="menu-item menu-item-4732 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="4732" href="https://owensborodiocese.org/catholic-schools-2/"><span>Catholic Schools</span></a></li><li class="menu-item menu-item-4734 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="4734" href="https://owensborodiocese.org/clergy/"><span>Clergy</span></a></li><li class="menu-item menu-item-4735 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="4735" href="https://owensborodiocese.org/family-life-2/"><span>Family Life</span></a></li><li class="menu-item menu-item-4737 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="4737" href="https://owensborodiocese.org/human-resources-2/"><span>Human Resources</span></a></li><li class="menu-item menu-item-4738 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="4738" href="https://owensborodiocese.org/parish/"><span>Parish</span></a></li><li class="menu-item menu-item-4739 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="4739" href="https://owensborodiocese.org/safe-environment/"><span>Safe Environment</span></a></li><li class="menu-item menu-item-4940 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="4940" href="https://owensborodiocese.org/diocesan-forms/"><span>Diocesan Forms</span></a></li></ul></li><li class="menu-item menu-item-5376 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="5376" href="https://owensborodiocese.org/diocesan-reports/"><span>Diocesan Reports</span></a></li></ul></li><li class="menu-item menu-item-1249 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="1249" href="https://owensborodiocese.org/our-faith/"><span>Our Faith</span></a><ul class="sub-menu"><li class="menu-item menu-item-1251 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1251" href="https://owensborodiocese.org/about-catholicism/"><span>About Catholicism</span></a></li><li class="menu-item menu-item-1250 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="1250" href="https://owensborodiocese.org/become-catholic/"><span>Become Catholic</span></a><ul class="sub-menu"><li class="menu-item menu-item-1481 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1481" href="https://owensborodiocese.org/rcia/"><span>RCIA</span></a></li></ul></li></ul></li><li class="menu-item menu-item-2311 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="2311" href="https://owensborodiocese.org/our-mission/"><span>Our Mission</span></a><ul class="sub-menu"><li class="menu-item menu-item-1161 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="1161" href="https://owensborodiocese.org/pastoral-plan/"><span>Pastoral Plan</span></a><ul class="sub-menu"><li class="menu-item menu-item-1160 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1160" href="https://owensborodiocese.org/vision-statement-one/"><span>Vision Statement One: GO!</span></a></li><li class="menu-item menu-item-1159 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1159" href="https://owensborodiocese.org/vision-statement-two/"><span>Vision Statement Two: Make Disciples</span></a></li><li class="menu-item menu-item-1158 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="1158" href="https://owensborodiocese.org/vision-statement-three/"><span>Vision Statement Three: Teach</span></a></li></ul></li><li class="menu-item menu-item-4285 menu-item-type-post_type menu-item-object-page menu-slug-primary"><a menu-id="4285" href="https://owensborodiocese.org/evangelization/"><span>Evangelization</span></a></li></ul></li><li class="menu-item menu-item-8302 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="8302" href="https://owensborodiocese.org/covid-2019/"><span>COVID-19</span></a></li><li class="menu-item menu-item-8920 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="8920" href="https://owensborodiocese.org/give/"><span>Give</span></a></li><li class="menu-item menu-item-298 menu-item-type-post_type menu-item-object-page menu-slug-secondary menu-item-has-children"><a menu-id="298" href="https://owensborodiocese.org/vocations/"><span>Vocations</span></a><ul class="sub-menu"><li class="menu-item menu-item-3578 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="3578" href="https://owensborodiocese.org/called-by-name/"><span>Called by Name</span></a></li><li class="menu-item menu-item-8115 menu-item-type-custom menu-item-object-custom menu-slug-secondary"><a menu-id="8115" href="https://owensborovocations.com/rosary/"><span>Matthew 9 Mission</span></a></li><li class="menu-item menu-item-319 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="319" href="https://owensborodiocese.org/men-religious/"><span>Men Religious</span></a></li><li class="menu-item menu-item-320 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="320" href="https://owensborodiocese.org/permanent-diaconate/"><span>Permanent Diaconate</span></a></li><li class="menu-item menu-item-321 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="321" href="https://owensborodiocese.org/priesthood/"><span>Priesthood</span></a></li><li class="menu-item menu-item-3385 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="3385" href="https://owensborodiocese.org/vocare/"><span>VOCARE</span></a></li><li class="menu-item menu-item-3322 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="3322" href="https://owensborodiocese.org/vocation-plan/"><span>Vocation Plan</span></a></li><li class="menu-item menu-item-322 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="322" href="https://owensborodiocese.org/women-religious/"><span>Women Religious</span></a></li></ul></li><li class="menu-item menu-item-840 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="840" href="https://owensborodiocese.org/offices/"><span>Offices & Ministries</span></a></li><li class="menu-item menu-item-304 menu-item-type-post_type menu-item-object-page menu-slug-secondary menu-item-has-children"><a menu-id="304" href="https://owensborodiocese.org/news/"><span>News</span></a><ul class="sub-menu"><li class="menu-item menu-item-325 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="325" href="https://owensborodiocese.org/subscribe/"><span>Subscribe</span></a></li></ul></li><li class="menu-item menu-item-301 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="301" href="https://owensborodiocese.org/calendar/"><span>Calendar</span></a></li><li class="menu-item menu-item-1579 menu-item-type-custom menu-item-object-custom menu-slug-secondary"><a menu-id="1579" href="/category/directory/"><span>Directory</span></a></li><li class="menu-item menu-item-6939 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="6939" href="https://owensborodiocese.org/employment/"><span>Employment</span></a></li><li class="menu-item menu-item-299 menu-item-type-post_type menu-item-object-page menu-slug-tertiary"><a menu-id="299" href="https://owensborodiocese.org/find-a-school/"><span>Find A School</span></a></li><li class="menu-item menu-item-300 menu-item-type-post_type menu-item-object-page menu-slug-tertiary"><a menu-id="300" href="https://owensborodiocese.org/find-a-parish/"><span>Find A Parish</span></a></li><li class="menu-item menu-item-324 menu-item-type-post_type menu-item-object-page menu-slug-tertiary"><a menu-id="324" href="https://owensborodiocese.org/find-a-mass/"><span>Find A Mass</span></a></li></ul></nav><div class="wrap">
<a href="#main" class="skip-content screen-reader-text">Skip to content</a>
<div class="part top">
<div class="inset">
<header role="banner">
<a href="https://owensborodiocese.org" class="logo"><span><img src="https://owensborodiocese.org/wp-content/themes/owensborodiocese/_elements/logo.png" alt="logo"></span><span class="screen-reader-text">Diocese of Owensboro</span></a> </header>
<nav role="navigation" class="nav horizontal secondary" data-depth="1"><h1 style="display:none;">&nbsp;</h1><ul class="rps-nav-menus"><li class="menu-item menu-item-8302 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="8302" href="https://owensborodiocese.org/covid-2019/"><span>COVID-19</span></a></li><li class="menu-item menu-item-8920 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="8920" href="https://owensborodiocese.org/give/"><span>Give</span></a></li><li class="menu-item menu-item-298 menu-item-type-post_type menu-item-object-page menu-slug-secondary menu-item-has-children"><a menu-id="298" href="https://owensborodiocese.org/vocations/"><span>Vocations</span></a></li><li class="menu-item menu-item-840 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="840" href="https://owensborodiocese.org/offices/"><span>Offices & Ministries</span></a></li><li class="menu-item menu-item-304 menu-item-type-post_type menu-item-object-page menu-slug-secondary menu-item-has-children"><a menu-id="304" href="https://owensborodiocese.org/news/"><span>News</span></a></li><li class="menu-item menu-item-301 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="301" href="https://owensborodiocese.org/calendar/"><span>Calendar</span></a></li><li class="menu-item menu-item-1579 menu-item-type-custom menu-item-object-custom menu-slug-secondary"><a menu-id="1579" href="/category/directory/"><span>Directory</span></a></li><li class="menu-item menu-item-6939 menu-item-type-post_type menu-item-object-page menu-slug-secondary"><a menu-id="6939" href="https://owensborodiocese.org/employment/"><span>Employment</span></a></li></ul></nav> <div class="search-social">
<form role="search" method="get" class="search-form" action="https://owensborodiocese.org/"><div><label><span class="screen-reader-text">Search for:</span><input type="text" value="" name="s" class="search-field" placeholder="Enter search terms"><input type="hidden" value="0" name="rform"></label><input type="submit" value="Search"></div></form><nav role="navigation" class="nav horizontal social" data-depth="1"><h1 style="display:none;">&nbsp;</h1><ul class="rps-nav-menus"><li class="menu-item menu-item-1566 menu-item-type-custom menu-item-object-custom menu-slug-social"><a menu-id="1566" href="https://www.facebook.com/DioceseOfOwensboro/"><span>facebook</span></a></li><li class="menu-item menu-item-1569 menu-item-type-custom menu-item-object-custom menu-slug-social"><a menu-id="1569" href="https://twitter.com/Owensboro1937"><span>twitter</span></a></li><li class="menu-item menu-item-1570 menu-item-type-custom menu-item-object-custom menu-slug-social"><a menu-id="1570" href="https://www.instagram.com/owensborodiocese/"><span>instagram</span></a></li><li class="menu-item menu-item-1574 menu-item-type-custom menu-item-object-custom menu-slug-social"><a menu-id="1574" href="https://vimeo.com/rcdok"><span>vimeo</span></a></li></ul></nav> </div>
</div>
</div>
<div class="part middle">
<div class="inset">
<nav role="navigation" class="nav horizontal primary" data-depth="1"><h1 style="display:none;">&nbsp;</h1><ul class="rps-nav-menus"><li class="menu-item menu-item-290 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="290" href="https://owensborodiocese.org/our-diocese/"><span>Our Diocese</span></a></li><li class="menu-item menu-item-1249 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="1249" href="https://owensborodiocese.org/our-faith/"><span>Our Faith</span></a></li><li class="menu-item menu-item-2311 menu-item-type-post_type menu-item-object-page menu-slug-primary menu-item-has-children"><a menu-id="2311" href="https://owensborodiocese.org/our-mission/"><span>Our Mission</span></a></li></ul></nav><nav role="navigation" class="nav horizontal tertiary" data-depth="1"><h1 style="display:none;">&nbsp;</h1><ul class="rps-nav-menus"><li class="menu-item menu-item-299 menu-item-type-post_type menu-item-object-page menu-slug-tertiary"><a menu-id="299" href="https://owensborodiocese.org/find-a-school/"><span>Find A School</span></a></li><li class="menu-item menu-item-300 menu-item-type-post_type menu-item-object-page menu-slug-tertiary"><a menu-id="300" href="https://owensborodiocese.org/find-a-parish/"><span>Find A Parish</span></a></li><li class="menu-item menu-item-324 menu-item-type-post_type menu-item-object-page menu-slug-tertiary"><a menu-id="324" href="https://owensborodiocese.org/find-a-mass/"><span>Find A Mass</span></a></li></ul></nav>
<div class="columns"><div id="main" class="column primary" role="main">
<div class="inset">
<nav role="navigation" class="current--ancestor current-menu-ancestor nav breadcrumb" data-multi-level="true" data-depth="-1"><h1 style="display:none;">&nbsp;</h1><ul class="rps-nav-menus"><li class="menu-item menu-item-485 menu-item-type-auto_nav_menu_item menu-item-object-category menu-slug-accountability current-auto_nav_menu_item-parent current-menu-ancestor current-menu-parent current-item-parent current-item-ancestor"><a menu-id="485" href="https://owensborodiocese.org/category/the-western-kentucky-catholic/"><span>The Western Kentucky Catholic</span></a></li></ul></nav><div class="turf content"><article id="post-8929" class="post-8929 post type-post status-publish format-standard has-post-thumbnail category-the-western-kentucky-catholic element-group h-entry">
<header><h1 class="turf p-name entry-title">‘Even if it’s tomorrow or a thousand years’ &#8211; ‘Unashamed’ faith of Logan Davis revealed wisdom beyond his 18 years</h1><div class="turf post-date"><time datetime="2020-09-15T09:56:28-05:00">September 15, 2020</time></div></header><div class="turf e-content entry-content"><figure id="attachment_8931" class="turf wp-caption aligncenter" style="max-width:768px"><img loading="lazy" class="wp-image-8931 size-medium" src="https://owensborodiocese.org/wp-content/uploads/LoganDavis_HaleyAndKarla_SeptWKC2020online-768x307.jpg" alt="" width="768" height="307" srcset="https://owensborodiocese.org/wp-content/uploads/LoganDavis_HaleyAndKarla_SeptWKC2020online-768x307.jpg 768w, https://owensborodiocese.org/wp-content/uploads/LoganDavis_HaleyAndKarla_SeptWKC2020online-1024x410.jpg 1024w, https://owensborodiocese.org/wp-content/uploads/LoganDavis_HaleyAndKarla_SeptWKC2020online.jpg 1500w" sizes="(max-width: 768px) 100vw, 768px" /> <figcaption id="figcaption_attachment_8931" class="wp-caption-text">Logan Davis (center) with sister Haley Davis (left) and mother Karla Davis (right). COURTESY OF DAVIS FAMILY</figcaption></figure>
<hr />
<p>BY ELIZABETH WONG BARNSTEAD, THE WESTERN KENTUCKY CATHOLIC</p>
<p>Logan Davis’s sister, Haley Davis, is the one who discovered the journal.</p>
<p>They hadn’t known that Logan had kept a journal. And “it wasn’t something that was filled with lots of pages,” said their mother, Karla Davis.</p>
<p>But among the pages, they found the following words:</p>
<p>“My God, my God, I love you. I love you. There is no words I can use to express my wanting to be with you in heaven, the goal and our destiny. I’m ready whenever you call my spirit home, its yours. I ask that when you call me home that everyone will be happy not sad, for they will know that we love them. Until this moment I’ll keep praying. I’ll keep loving you even if it’s tomorrow or a thousand years.”<span id="more-8929"></span></p>
<p>There was no date on the entry, and they determined it had been several years since Logan had touched the journal.</p>
<p>But it was clear that “he wasn’t scared to put that stuff down on paper,” said Haley.</p>
<p>She said that some notes found on his cellphone had similar spiritual reflections: “Maybe not like a collective journal, nothing daily, but he wasn’t ashamed for sure to put that stuff down.”</p>
<p>That entry, said Karla, “has touched a lot of people.”</p>
<p><strong>One of the best</strong></p>
<p>The community at <a href="https://owensborodiocese.org/listing/owensboro-catholic-high-school/">Owensboro Catholic High School</a> – and all throughout western Kentucky – was shaken by the news of football player and rising senior Logan Allen Davis’s death on July 11, 2020 following a one-vehicle auto accident.</p>
<p>The 6-foot-3, 320-pound offensive guard and defensive tackle had just turned 18 on May 5.</p>
<p>After the Owensboro Catholic School System posted the news of Logan’s passing on its Facebook page, the post was quickly flooded with comments offering condolences and prayers, as well as witnesses of the young man’s faith.</p>
<p>Sharon Johnson, a teacher at <a href="https://owensborodiocese.org/listing/owensboro-catholic-schools-k-3-campus/">Owensboro Catholic Schools’ K-3 Campus</a>, commented that not only was Logan one of her favorite students, but “one of my favorite people.”</p>
<p>“The kindest heart and the brightest smile,” wrote Johnson. “Logan preached kindness and compassion to everyone from the time he was in kindergarten way before it was ever put on a sign reminding you to do so. My love and prayers for the entire Davis family and our OC family. We have lost one of the best.”</p>
<p>Diocesan seminarian Deacon Corey Bruns, who had gotten to know Logan as a camper when Deacon Bruns was working at <a href="http://www.gasperriverretreatcenter.org/">Gasper River Catholic Youth Camp and Retreat Center</a>, posted on his own Facebook timeline that “Logan was a wonderful young man who truly loved the Lord.”</p>
<p>“I always enjoyed seeing him at the different youth events across the diocese and hearing how the Lord was moving in his life,” wrote Deacon Bruns. “May he have the joy of seeing the Lord he loved and served face to face and may eternal rest be his.”</p>
<p>The funeral Mass was held outdoors on July 15 at Steele Stadium in Owensboro, officiated by Fr. Jason McClure, OCHS chaplain; and Fr. John Vaughan, pastor of <a href="https://owensborodiocese.org/listing/parish-of-the-immaculate">Immaculate Parish</a> where the Davis family are members.</p>
<p>According to a July 16 story by the Messenger-Inquirer, approximately 1,000 mourners filled the stands.</p>
<p>The funeral programs that were distributed contained a copy of the journal entry that Haley and Karla had found.</p>
<figure id="attachment_8932" class="turf wp-caption aligncenter" style="max-width:600px"><img loading="lazy" class="wp-image-8932 size-full" src="https://owensborodiocese.org/wp-content/uploads/LoganDavis_MarchForLife_SeptWKC2020online.jpg" alt="" width="600" height="800" /> <figcaption id="figcaption_attachment_8932" class="wp-caption-text">Logan Davis (far right) with several friends at the Basilica of the National Shrine of the Immaculate Conception in Washington, D.C., during a trip to the March for Life. COURTESY OF DAVIS FAMILY</figcaption></figure>
<hr />
<p><strong>From deep within</strong></p>
<p>Logan’s friends have told Karla that her son had often said he wasn’t afraid of dying.</p>
<p>“And he would tell them that he thought he would be the first one to die,” said Karla in an Aug. 13, 2020 interview with The Western Kentucky Catholic.</p>
<p>“I don’t know where that comes from,” said Karla. “Most people at that age don’t even consider that kind of stuff.”</p>
<p>Then again, Karla and Haley know Logan wasn’t like most people his age.</p>
<p>“He’s been that way for a long time,” said Karla, adding that Logan had attended Catholic school since kindergarten and had participated in many youth ministry opportunities, as well as benefitting from attending church as a family.</p>
<p>And Gasper River, said Karla, “was huge for him.”</p>
<p>She said Logan had attended the diocesan camp and retreat center located near Bowling Green as soon as he was old enough, “and he absolutely loved it.”</p>
<p>“I feel like that deepened his faith a lot, but I feel like something, too, came from within him,” said Karla. “A lot of that he developed on his own.”</p>
<p>Haley added that, “even just small things, like when he was younger, wearing a crucifix around his neck all the time,” were a testament to the faith of her brother, who also wore a scapular every day.  </p>
<p>From a young age Logan would talk about becoming a priest, and while perhaps that wasn’t his most recent plan, Haley said the priesthood “definitely was something he considered for a long time and was open to.”</p>
<p>This was also apparent when Logan made his Confirmation, and he chose the name Paul after St. Paul, the early Church evangelist.  </p>
<p>Bishop William F. Medley has a tradition during the Confirmation liturgy of reading excerpts from letters that the confirmandi write to him. The portion he selected from Logan’s had included the statement that, “I’m aware that God might be calling me to be a priest.’”</p>
<p>“He wanted to learn, too,” said Haley. “He wanted to learn all about (the Catholic faith). He would read things, and ask questions, and was truly interested in all of it.”</p>
<p><strong>Selfless protector</strong></p>
<p>Haley said she always felt a sense of responsibility for her brother, four years her junior, but as he grew up the roles were reversed.</p>
<p>“Even his friends would say that he was very protective of both of us,” she said.</p>
<p>She and her mother have learned that Logan would talk about the two of them all the time with his friends – who were nicknamed “the Bros.”</p>
<p>“His friends all said, ‘Logan loved you guys so much,’” said Karla, who would receive a text message every day from Logan telling her that he loved her. “We told them the same, because he adored his friends.”</p>
<p>Karla said her son “loved with everything he had,” and wanted to “help people have strong faith and a strong relationship with God.”</p>
<p>Haley described her brother as “selfless,” explaining that from time to time, if someone texted Logan with a problem, “he was right there; he was all about it.”</p>
<p>“Or maybe there was a kid who didn’t have a huge group of friends like he did, and they were having a rough night, so he would bring them along,” said Haley. “Just things like that. He was unapologetically himself. He didn’t care what people thought.”</p>
<figure id="attachment_8934" class="turf wp-caption aligncenter" style="max-width:600px"><img loading="lazy" class="wp-image-8934 size-full" src="https://owensborodiocese.org/wp-content/uploads/LoganDavis_Priests_SeptWKC2020online.jpg" alt="" width="600" height="800" /> <figcaption id="figcaption_attachment_8934" class="wp-caption-text">Fr. Jason McClure, Logan Davis, and Fr. Richard Powers. COURTESY OF DAVIS FAMILY</figcaption></figure>
<hr />
<p><strong>An anonymous gift</strong></p>
<p>“That” journal entry of Logan’s went viral on social media following the funeral.</p>
<p>And recently, some of Karla’s friends from back in college came to visit her. They brought her a gift.</p>
<p>It turned out that a friend-of-a-friend had seen the social media post with Logan’s journal entry. This friend, who remained anonymous, made something for Karla.</p>
<p>It was a piece of wood with the journal entry engraved on it, “and they got a copy of Logan’s signature and put it on there,” said Karla.</p>
<p>“I don’t know who it’s from; it was somebody not even ‘here’ who was so touched by that journal entry and his faith and how deep his faith was,” she added. “That was probably my favorite gift I’ve ever received.”</p>
<p>Karla said that the more that journal entry “gets out there,” she feels “the more people it will touch.”</p>
<p>“It sounds like it was written by somebody way beyond his years,” she said.  </p>
<p>Karla told a story about a young girl who approached her at the funeral home and told her, “I’m not Catholic, but Logan and I had a big conversation not that long ago about religion and faith,” changing the girl’s “whole outlook.”</p>
<p>“She was now more into her faith,” said Karla. “Just… oh my gosh, this is crazy for an 18-year-old… and even older people have made comments about being drawn to him, or about how they admired him and how he lived his faith,” she said.</p>
<p>“It’s overwhelming, it’s humbling to think of the impact he’s had on people,” said Karla.</p>
<hr />
<blockquote>
<h6>‘Coach, how are you doing?’</h6>
<p><em>Athletic director says he will miss ‘Big 68’</em></p>
<p>Jason Morris, athletic director and head football coach of Owensboro Catholic High School, said that in his 17 years of coaching, “I never coached a player more committed to outwardly living life in a way that expressed his faith in Jesus” than Logan Davis.</p>
<p>“Logan was a kind, caring, and compassionate teammate and friend,” said Morris. “He never wanted to do anything that would displease someone, especially one of his friends or coaches.”</p>
<p>Morris said the young man’s smile would “light up a room” and make “everybody’s purpose seem a little bit clearer.”</p>
<p>“I always knew that when I didn&#8217;t have the words to say at the time, that I could always count on Logan to go to for prayers,” said Morris.</p>
<p>Morris said that without a doubt, these past few weeks since the 18-year-old’s death have been the hardest in his coaching career.</p>
<p>“The relationships that I build with my players are special to me and the relationship that I built with Logan over the past four years was special as well,” said Morris. “Logan would always ask, ‘Coach, how are you doing?’ I never once thought he was asking out of habit, but he genuinely wanted to know how Coach was doing and he cared.”</p>
<p>“Words cannot describe the kind of coaches’ love that I have for Logan and I am genuinely going to miss Big 68,” said Morris.</p>
</blockquote>
<hr />
<p><em>Originally printed in the September 2020 issue of <a href="https://owensborodiocese.org/western-kentucky-catholic/">The Western Kentucky Catholic</a>.</em></p>
<hr />
<div id="main" role="main">
<div>
<div>
<article id="post-6485">
<div>
<p>Copyright © 2020 Diocese of Owensboro/The Western Kentucky Catholic</p>
</div>
</article>
</div>
</div>
</div>
</div><footer></footer></article>
</div> </div>
</div><div class="column secondary">
<div class="inset">
<div class="widgets"><div class="inset"><div class="grid-sizer"></div><div class="gutter-sizer"></div><aside id="archives-3" class="widget widget_archive"><div class="inset"><div class="widget-wrap"><h1>News Archives</h1>
<ul>
<li><a href='https://owensborodiocese.org/2020/09/'>September 2020</a></li>
<li><a href='https://owensborodiocese.org/2020/08/'>August 2020</a></li>
<li><a href='https://owensborodiocese.org/2020/07/'>July 2020</a></li>
<li><a href='https://owensborodiocese.org/2020/06/'>June 2020</a></li>
<li><a href='https://owensborodiocese.org/2020/05/'>May 2020</a></li>
<li><a href='https://owensborodiocese.org/2020/04/'>April 2020</a></li>
<li><a href='https://owensborodiocese.org/2020/03/'>March 2020</a></li>
<li><a href='https://owensborodiocese.org/2020/02/'>February 2020</a></li>
<li><a href='https://owensborodiocese.org/2020/01/'>January 2020</a></li>
<li><a href='https://owensborodiocese.org/2019/12/'>December 2019</a></li>
<li><a href='https://owensborodiocese.org/2019/11/'>November 2019</a></li>
<li><a href='https://owensborodiocese.org/2019/10/'>October 2019</a></li>
<li><a href='https://owensborodiocese.org/2019/09/'>September 2019</a></li>
<li><a href='https://owensborodiocese.org/2019/08/'>August 2019</a></li>
<li><a href='https://owensborodiocese.org/2019/06/'>June 2019</a></li>
<li><a href='https://owensborodiocese.org/2019/05/'>May 2019</a></li>
<li><a href='https://owensborodiocese.org/2019/04/'>April 2019</a></li>
<li><a href='https://owensborodiocese.org/2019/03/'>March 2019</a></li>
<li><a href='https://owensborodiocese.org/2019/02/'>February 2019</a></li>
<li><a href='https://owensborodiocese.org/2019/01/'>January 2019</a></li>
<li><a href='https://owensborodiocese.org/2018/12/'>December 2018</a></li>
<li><a href='https://owensborodiocese.org/2018/11/'>November 2018</a></li>
<li><a href='https://owensborodiocese.org/2018/10/'>October 2018</a></li>
<li><a href='https://owensborodiocese.org/2018/09/'>September 2018</a></li>
<li><a href='https://owensborodiocese.org/2018/08/'>August 2018</a></li>
<li><a href='https://owensborodiocese.org/2018/06/'>June 2018</a></li>
<li><a href='https://owensborodiocese.org/2018/05/'>May 2018</a></li>
<li><a href='https://owensborodiocese.org/2018/04/'>April 2018</a></li>
<li><a href='https://owensborodiocese.org/2018/03/'>March 2018</a></li>
<li><a href='https://owensborodiocese.org/2018/02/'>February 2018</a></li>
<li><a href='https://owensborodiocese.org/2018/01/'>January 2018</a></li>
<li><a href='https://owensborodiocese.org/2017/12/'>December 2017</a></li>
<li><a href='https://owensborodiocese.org/2017/10/'>October 2017</a></li>
<li><a href='https://owensborodiocese.org/2017/09/'>September 2017</a></li>
<li><a href='https://owensborodiocese.org/2017/08/'>August 2017</a></li>
<li><a href='https://owensborodiocese.org/2017/07/'>July 2017</a></li>
<li><a href='https://owensborodiocese.org/2017/05/'>May 2017</a></li>
<li><a href='https://owensborodiocese.org/2017/03/'>March 2017</a></li>
<li><a href='https://owensborodiocese.org/2017/02/'>February 2017</a></li>
<li><a href='https://owensborodiocese.org/2017/01/'>January 2017</a></li>
<li><a href='https://owensborodiocese.org/2016/12/'>December 2016</a></li>
<li><a href='https://owensborodiocese.org/2016/11/'>November 2016</a></li>
<li><a href='https://owensborodiocese.org/2016/10/'>October 2016</a></li>
<li><a href='https://owensborodiocese.org/2016/09/'>September 2016</a></li>
<li><a href='https://owensborodiocese.org/2016/08/'>August 2016</a></li>
<li><a href='https://owensborodiocese.org/2016/07/'>July 2016</a></li>
<li><a href='https://owensborodiocese.org/2016/06/'>June 2016</a></li>
<li><a href='https://owensborodiocese.org/2016/05/'>May 2016</a></li>
<li><a href='https://owensborodiocese.org/2016/04/'>April 2016</a></li>
<li><a href='https://owensborodiocese.org/2016/03/'>March 2016</a></li>
<li><a href='https://owensborodiocese.org/2016/02/'>February 2016</a></li>
<li><a href='https://owensborodiocese.org/2016/01/'>January 2016</a></li>
<li><a href='https://owensborodiocese.org/2015/12/'>December 2015</a></li>
</ul>
</div></div></aside></div></div> </div>
</div><div class="column tertiary">
<div class="inset">
</div>
</div>
</div>
</div>
</div>
<div class="part bottom">
<div class="inset">
<footer role="contentinfo">
<address><span>Diocese of Owensboro</span> <span>600 Locust Street</span> <span>Owensboro, KY 42301</span> <span>270-683-1545</span></address>
<nav role="navigation" class="nav horizontal footer" data-depth="1"><h1 style="display:none;">&nbsp;</h1><ul class="rps-nav-menus"><li class="menu-item menu-item-5705 menu-item-type-post_type menu-item-object-page menu-slug-footer menu-item-has-children"><a menu-id="5705" href="https://owensborodiocese.org/privacy-policy/"><span>Privacy Policy</span></a></li></ul></nav> </footer>
<nav role="navigation" class="nav horizontal apps" data-depth="1"><h1 style="display:none;">&nbsp;</h1><ul class="rps-nav-menus"><li class="menu-item menu-item-2167 menu-item-type-custom menu-item-object-custom menu-slug-apps"><a menu-id="2167" href="https://itunes.apple.com/us/app/diocese-of-owensboro/id613643913"><span>Apple</span></a></li><li class="menu-item menu-item-2168 menu-item-type-custom menu-item-object-custom menu-slug-apps"><a menu-id="2168" href="https://play.google.com/store/apps/details?id=com.redpixel.infoapp.m.client.dioceseowensboro"><span>Google</span></a></li></ul></nav><p class="copyright">&copy;2020 Diocese of Owensboro - All Rights Reserved</p><p class="credit"><a href="http://redpixel.com/">Red Pixel Studios</a></p> </div>
</div>
</div>
<script type='text/javascript' src='https://owensborodiocese.org/wp-content/plugins/appbanners/lib/smartbanner/jquery.smartbanner.min.js?ver=2ee5fdeb12d9b11e4dfc9f800f3d4c4b' id='app-banners-scripts-js'></script>
<script type='text/javascript' id='app-banners-custom-scripts-js-extra'>
/* <![CDATA[ */
var appBannersConfig = {"title":"Diocese of Owensboro","author":"Red Pixel Studios, Inc.","price":"Free","appStoreLanguage":"US","inAppStore":"On the App Store","inGooglePlay":"In Google Play","inAmazonAppStore":"In the Amazon Appstore","inWindowsStore":"In the Windows Store","GooglePlayParams":null,"icon":"","iconGloss":"","url":"","button":"","scale":"auto","speedIn":"300","speedOut":"400","daysHidden":"0","daysReminder":"0","force":null,"hideOnInstall":"1","layer":"","iOSUniversalApp":"1","appendToSelector":"body","printViewPort":"1","pushSelector":"html"};
/* ]]> */
</script>
<script type='text/javascript' src='https://owensborodiocese.org/wp-content/plugins/appbanners/js/config.min.js?ver=2ee5fdeb12d9b11e4dfc9f800f3d4c4b' id='app-banners-custom-scripts-js'></script>
<script type='text/javascript' id='cookie-consent-js-extra'>
/* <![CDATA[ */
var ctcc_vars = {"expiry":"30","method":"","version":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://owensborodiocese.org/wp-content/plugins/uk-cookie-consent/assets/js/uk-cookie-consent-js.js?ver=2.3.0' id='cookie-consent-js'></script>
<script type='text/javascript' id='donot-sell-form-js-extra'>
/* <![CDATA[ */
var localized_donot_sell_form = {"admin_donot_sell_ajax_url":"https:\/\/owensborodiocese.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://owensborodiocese.org/wp-content/plugins/gdpr-framework/assets/js/gdpr-donotsell.js?ver=1.0.0' id='donot-sell-form-js'></script>
<script type='text/javascript' src='https://owensborodiocese.org/wp-content/themes/owensborodiocese/turf/js/scripts.js?ver=6.4.19' id='rps-turf-script-scripts-js'></script>
<script type='text/javascript' src='https://owensborodiocese.org/wp-content/themes/owensborodiocese/_scripts/theme.js?ver=2ee5fdeb12d9b11e4dfc9f800f3d4c4b' id='theme-script-theme-js'></script>
<script type='text/javascript' id='rps_contacts_directory_hours_of_operation-js-extra'>
/* <![CDATA[ */
var rps_contacts_directory_hours_of_operation = {"midnight":"Midnight","noon":"Noon","allDay":"All Day","sun":"SUN","mon":"MON","tue":"TUE","wed":"WED","thu":"THU","fri":"FRI","sat":"SAT","sunday":"Sunday","monday":"Monday","tuesday":"Tuesday","wednesday":"Wednesday","thursday":"Thursday","friday":"Friday","saturday":"Saturday","opens":"Opens","closes":"Closes","open":"OPEN","closed":"CLOSED","day":"Day","schedule":"Schedule","scheduleToggle":"Schedule Toggle","at":"at","am":"AM","pm":"PM"};
/* ]]> */
</script>
<script type='text/javascript' src='https://owensborodiocese.org/wp-content/plugins/rps-contacts-directory/rps-contacts-hours-of-operation.js?ver=1.2' id='rps_contacts_directory_hours_of_operation-js'></script>
<script type="text/javascript">
					jQuery(document).ready(function($){
												if(!catapultReadCookie("catAccCookies")){ // If the cookie has not been set then show the bar
							$("html").addClass("has-cookie-bar");
							$("html").addClass("cookie-bar-top-bar");
							$("html").addClass("cookie-bar-bar");
															// Wait for the animation on the html to end before recalculating the required top margin
								$("html").on('webkitTransitionEnd otransitionend oTransitionEnd msTransitionEnd transitionend', function(e) {
									// code to execute after transition ends
									var barHeight = $('#catapult-cookie-bar').outerHeight();
									$("html").css("margin-top",barHeight);
									$("body.admin-bar").css("margin-top",barHeight-32); // Push the body down if the admin bar is active
								});
													}
																	});
				</script>
<div id="catapult-cookie-bar" class=""><div class="ctcc-inner "><span class="ctcc-left-side">This site uses cookies to improve user experience and track usage. <a class="ctcc-more-info-link" tabindex=0 target="_blank" href="https://owensborodiocese.org/privacy-policy/">Read our Privacy Policy.</a></span><span class="ctcc-right-side"><button id="catapultCookie" tabindex=0 onclick="catapultAcceptCookies();">Accept</button></span></div></div></body>
</html>
